Close

lambda expression are not supported at language level 7

appの build.gradleにsourceCompatibilityと targetCompatibilityを記述しても警告が消えない。

android {
	…
	compileOptions {
		sourceCompatibility JavaVersion.VERSION_1_8
		targetCompatibility JavaVersion.VERSION_1_8
	}
	…

少し調べて書き方を変えてみたところ無事に警告が消えた。

android {
	…
	compileOptions {
		sourceCompatibility = JavaVersion.VERSION_1_8
		targetCompatibility = JavaVersion.VERSION_1_8
	}
	…

ただ、モジュールの方は前述の書き方で警告は出ないんだよなぁ?

Leave a Reply

Your email address will not be published. Required fields are marked *

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)